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1. Introduction 
AEOS lets you generate and print QR codes and use them as identifiers. This feature is available in 
AEOS 3.4 and newer versions. 

Whether they’re printed or digital, QR codes replace the need for physical plastic cards, which 
makes using them as identifiers a cost-effective, smart and sustainable option. It saves the costs of 
buying, handling and printing plastic cards. And, while QR code solutions aren’t suitable for high-
security areas, they can help to improve the efficiency of handling visitors in common areas of 
buildings or in car parks. 

A typical example of how they can be used is to send a QR code to a visitor’s mobile phone, which 
allows them to enter a car park without having to call reception. They just present the QR code to 
the QR reader to gain access. 

QR code model 2 

AEOS QR codes are based on QR code model 2. They contain the customer code, identifier 
number, carrier name and validity. You can use any QR reader that supports QR code model 2 and 
OSDP or Wiegand to scan them. 

OSDP or Wiegand protocol 

The AEOS QR code functionality uses either the OSDP or the Wiegand protocol. 

MACE MM QR reader 

In this manual, we use the Nedap MACE MM QR Reader to read the AEOS QR codes. This device 
includes a QR reader that enables reading QR-codes displayed on a smartphone. For more 
information on the Nedap MACE MM QR Reader, please visit www.nedapidentification.com. 

About this manual 

This manual describes how you can use QR codes as identifiers in AEOS. 

Chapter 2 shows you how the reader hardware must be connected to the AEOS Blue controller. 

The next chapters provide step-by-step instructions to configure the QR code reader and AEmon 
for an OSDP interface (chapter 3 and 4) or a Wiegand interface (chapter 5 and 6). 

Chapter 7 and 8 describe how to configure AEOS and how to actually issue QR code identifiers. 

When a QR code is presented to the QR reader, an event must show in the AEmon event monitor. 
How you can check this is described in chapter 9. 

Finally, chapter 10 contains recommendations to optimise QR code security by using different 
AEOS options and check AEOS system property settings. 

http://www.qrcode.com/en/codes/model12.html


Installation and Configuration | AEOS QR code EN 

 Manual version 2 5/30 

2. Connection overview 

2.1 Connection overview for an OSDP interface 
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2.2 Connection overview for a Wiegand interface 
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3. Configuring the QR code reader (MACE reader) for OSDP 
AEOS QR codes are based on QR code model 2. They contain the customer code, identifier 
number, carrier name and validity. You can use any QR reader that supports QR code model 2 and 
OSDP or Wiegand to scan them. In this manual, we use the Nedap MACE MM QR Reader to read the 
AEOS QR codes. This device includes a QR reader that enables reading QR-codes displayed on a 
smartphone. For more information on the Nedap MACE MM QR Reader, please visit 
www.nedapidentification.com. 

The information in the AEOS QR code is encoded as a text (ASCII) string value. The MACE MM QR 
reader can only push the string value to its serial interface, which is the USB or RS485. After 
removing the text characters, the MACE MM QR reader can convert the value to HEX or DEC. In this 
example, we will keep using the text string. 

In order to receive the string value, the AEOS Blue controller must connect to MACE MM QR reader 
using RS485 as OSDP interface. Both the MACE reader and the AEOS Blue controller must use the 
OSDP protocol. Therefore, the firmware for both the MACE reader and the AEOS Blue controller 
must be changed to OSDP. 

To configure the MACE reader for OSDP, take the following steps: 

  

Change the MACE reader firmware to OSDP 

 

1. Go to www.nedapidentification.com. Download and install the MACE configuration tool. 

2. Connect the MACE MM QR reader via USB to the computer. 

3. Open the MACE configuration tool. 

4. Click Firmware update. 

5. Click the 'open folder' icon and select the MACE MM QR OSDP firmware. 

6. Click Update. 

Step 

01 

http://www.qrcode.com/en/codes/model12.html
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After changing the firmware, the MACE reader will be disconnected. You must reconnect the MACE 
MM QR reader using the OSDP protocol. 

7. Click Connect. 

8. Select OSDP and check the other settings. 

9. Click OK. 
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Configure the QR-code function in the MACE MM QR reader 

 

1. Go to Options > User mode. Switch to the Advanced user mode. 

2. Enable the QR-code function. 
 

 
 

3. Set the check prefix string to : and the check suffix string value to >. 
These options are used to determine the ID number location. The MACE MM QR reader needs 
them to push only the ID-number and not the other characters. The Check prefix string is : 
because AEOS puts this character in front of the ID number. The Check suffix string is > 
because AEOS puts this character behind the ID number. 

 

Example 

Without these settings: 
 

 

With these settings:  
 

Step 

02 
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4. Set the string format to Text string.  
This option reads and pushes the value (ID-number) as text to AEOS. 

5. Click Serial output. Set ID-number to Complete. 
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4. Configuring AEmon for OSDP 
To configure AEmon for the QR code function via OSDP, take the following steps: 

  

Configure the AEOS Blue controller in AEmon 

 

1. Start AEmon. 

2. Select the AEOS Blue controller you want to update. 

3. Go to View > Hardware. 

4. In the Firmware section at the right side of the window, click the […] button next to the File 
field. This opens the C:\AEOS\scripts\firmware folder. The different firmware versions are 
stored in different subfolders. 

5. From the Files of type drop-down list, select the file type that is compatible with the selected 
hardware. This will only show the firmware files that are compatible with your selected 
hardware.  

6. Select the correct OSDP firmware file from the correct folder. 

7. Click Open. 

8. Click the Load button to start the firmware update. 
 

 

Step 

01 
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Configure the MACE reader as OSDP reader in AEmon 

 

1. In AEmon, create/open the configuration (see the AEOS Access Points and Entrances manual). 

2. Right-Click the BusDevice-Integrator AEbc, and click Properties. 

3. Open the device type editor and select OSDP. Click OK. 

4. Open the device configuration editor and enable Device 000. Click OK. 

5. Press CTRL+E and click Yes to deploy the configuration. 
 

 

 

 

 

 

 

 

 

 

 

 

Configuration example 

 
 

Step 

02 
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Configure the identifier type in AEmon 

 

1. Right-Click the StandardDoor AEbc, and click Properties. 

 
 

2. Open the Identifier type editor and select Generic. 

3. Set the Format to Ascii-numeric and select Numeric 

4. Set the Bit position to 16. Check the other settings. In this example, we set the Length to 6 
bytes (for we use a 6-digit number). Click OK. 

5. Press CTRL+E and click Yes to deploy the configuration. 
 

The identifier type settings must match the settings in AEOS, see chapter 7. 

 

Step 

03 
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5. Configuring the QR code reader (MACE reader) for Wiegand 
AEOS QR codes are based on QR code model 2. They contain the customer code, identifier 
number, carrier name and validity. You can use any QR reader that supports QR code model 2 and 
OSDP or Wiegand to scan them. In this manual, we use the Nedap MACE MM QR Reader to read the 
AEOS QR codes. This device includes a QR reader that enables reading QR-codes displayed on a 
smartphone. For more information on the Nedap MACE MM QR Reader, please visit 
www.nedapidentification.com. 

The information in the AEOS QR code is encoded as a text (ASCII) string value. After removing the 
text characters, the MACE MM QR reader can convert the value to HEX or DEC. In this example, the 
MACE MM QR reader will convert the value to DEC. 

To configure the MACE reader for Wiegand, take the following steps: 

  

Change the MACE reader firmware to Standard 

 

1. Go to www.nedapidentification.com. Download and install the MACE configuration tool. 

2. Connect the MACE MM QR reader via USB to the computer. 

3. Open the MACE configuration tool. 

4. Check the firmware. 
 

By default, the MACE reader already uses the standard firmware. Only when the default setting has 
been changed, you must reset it to Standard. 

 

5. Click Firmware update. 

6. Click the 'open folder' icon and select the MACE MM QR Standard firmware. 

7. Click Update. 
 

Step 

01 

http://www.qrcode.com/en/codes/model12.html
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After changing the firmware, the MACE reader will be disconnected. You must reconnect the MACE 
MM QR reader using the STANDARD protocol. 

8. Click Connect. 

9. Select STANDARD and check the other settings. 

10. Click OK. 
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Configure the QR-code function in the MACE MM QR reader 

 

1. Go to Options > User mode. Switch to the Advanced user mode. 

2. Enable the QR-code function.  
 

 
 

3. Set the check prefix string to : and the check suffix string value to >. 
These options are used to determine the ID number location. The MACE MM QR reader needs 
them to push only the ID-number and not the other characters. The Check prefix string is : 
because AEOS puts this character in front of the ID number. The Check suffix string is > 
because AEOS puts this character behind the ID number. 

4. Set the string format to Decimal string. 
This option reads and pushes the value (ID-number) as decimal string to AEOS. 

5. Click Wiegand/Magstripe. Select Wiegand and set the ID-number to Complete. 
 

Step 

02 
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Example 

Note that in the ID List the Type is now RAW and the ID-number is the HEX value of the decimal 
value (138276). 
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6. Configuring AEmon for Wiegand 
To configure AEmon for the QR code function via Wiegand, take the following steps: 

  

Configure the AEOS Blue controller in AEmon 

 

By default, the AEOS blue controller already uses the correct firmware for the Wiegand interface. 
Only when the default setting has been changed, you must change it back. 

 

1. Start AEmon. 

2. Select the AEOS Blue controller you want to update. 

3. Go to View > Hardware. 

4. In the Firmware section at the right side of the window, click the […] button next to the File 
field. This opens the C:\AEOS\scripts\firmware folder. The different firmware versions are 
stored in different subfolders. 

5. From the Files of type drop-down list, select the file type that is compatible with the selected 
hardware. This will only show the firmware files that are compatible with your selected 
hardware.  

6. Select the correct Wiegand firmware file from the correct folder. 

7. Click Open. 

8. Click the Load button to start the firmware update. 
 

 
  

Configure the MACE reader in AEmon 

 

1. In AEmon, create/open the configuration (see the AEOS Access Points and Entrances manual). 

2. Press CTRL+E and click Yes to deploy the configuration. 
 

Configuration example 

Step 

01 

Step 

02 
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Configure the identifier type in AEmon 

 

1. Right-Click the StandardDoor AEbc, and click Properties. 

 
 

2. Open the Identifier type editor and select Generic. 

3. Set the Format to Binary and select Numeric 

4. Set the Bit position to 8. Check the other settings. In this example, we set the Length to 24 bits 
(for we use a 6-digit number). Click OK. 

5. Press CTRL+E and click Yes to deploy the configuration. 

Step 

03 
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The identifier type settings must match the settings in AEOS, see chapter 7. 
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7. Configuring AEOS 
To configure AEOS for the QR code function, take the following steps: 

  

Define the QR code identifier type in AEOS 

 

To define the QR identifier type, which is a 'generic' AEOS identifier type, do as follows: 

1. Go to Administration > Maintenance > Identifiers > Identifier types. 

2. Click New. 

3. Enter a Name and Sub type, Customer code type, Identifier length, minimum value and 
maximum value. 

 

The identifier type settings must match the settings in AEmon, see chapter 4 (for OSDP) or 6 (for 
Wiegand). 

4. Enable the (random) token generator. 
Note that you can always enter a self-chosen identifier number when you issue a QR code 
identifier, even when the (random) token generator is enabled. 

5. Set the Printable option to Yes or Optional. 
When the Printable option for the QR code identifier type is set to Yes, the print dialogue will 
open automatically when you issue a QR code. When the Printable option is set to Optional, 
pressing the Print button will start the print dialogue. 

6. Set the Print format to QR code. 

7. Click OK. 
 

You can only use one printable identifier type at once, either a bar code or a QR code. 

 

 

Step 

01 
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Install printer 

 

AEOS uses Windows system printers to print QR codes, so there’s no need to install a special 
badge printer or label printer. 

  

Attach QR codes to e-mails (optional) 

 

QR codes can be attached to e-mails as .jpg files and sent automatically. To enable this, you must 
create a response (Send e-mail) to a user action (Issue badge). 

1. Go to Configuration > Responses > Response to user action. 

2. Click New. 

3. In the Response field, select Send E-mail. 

4. In the User action field, Select Issue badge. 

5. Click the [>>] button to edit the restrictions and select the carrier type and the QR code 
identifier type. 

6. Click OK. 

7. Select a Day/Time schedule. 

8. Select Enabled. 

9. Select Create. 

10. In the Notify field, select Person involved. 

11. Enter a Description, E-mail subject and body. 
For an overview of the available wildcards, see the Response to user action section in the 
AEOS User Manual. 

12. Enable the Attach QR code checkbox. 

13. Click OK. 

Step 

02 

Step 

03 
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Installation and Configuration | AEOS QR code EN 

 Manual version 2 25/30 

8. Issuing and printing QR codes 
To issue and print QR codes, do as follows: 

1. Go to the Visitor/Employee/Contractor > Announce screens. 

2. In the Identifier Type field, select the QR code identifier type. 

3. When the Printable option for the QR code identifier type is set to Yes, the print dialogue will 
open automatically when you issue a QR code. When the Printable option is set to Optional, 
press the Print button to open the print dialogue. 

4. Click OK to print the QR code. 

5. Close the print dialogue. 

6. Click OK to save the carrier data. 

 

The Print button can also be used to reprint QR codes that have already been issued. 

 

 

 
 
 

 

Issue and print a QR code identifier in AEOS 

 

Text read by QR reader: 
Id:138276><Name:Smith, John><From:Thu Aug 30 16:00:44 CEST 2018> 
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9. Checking the AEmon event monitor 
When a QR code is presented to the QR reader, an event must show in the AEmon event monitor: 

 

Example 1: OSDP 

This image shows an example of an AEmon event log for an OSDP interface. On the read value, 
(0000380)313338323736 is the ASCII value for 138276 (DEC). 

 

 
 

Example 2, Wiegand 

This image shows an example of an AEmon event log for a Wiegand interface. On the read value, 
(030818)021c24 is the HEX value for 138276 (DEC). 

 

 
 
 

For more information on the AEmon event monitor, see the AEOS Access Points and Entrances 
manual. 
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10. Security recommendations 
QR code solutions can help to improve the efficiency of handling visitors in common areas of 
buildings or in car parks. It is very convenient to assign QR codes to visitors and send these codes 
to them by email. This way, the visitor can access a common area or car park before they register 
at the reception desk. 

QR codes are not suitable for high-security areas. QR codes are reproducible and, by their nature, 
not highly secure. However, with AEOS, you have several options to optimise QR code security: 

• Withdraw the QR code identifier when it is no longer needed. A QR code identifier comes in a 
digital or printed form. Visitors will not go back to the reception desk and return the QR code 
identifier when they leave. So you must withdraw the QR code as soon as it is no longer 
needed. You can use the Response to event option in AEOS to withdraw the identifier 
automatically after use. Just like other identifiers, the visitor's QR code identifier will be 
removed from AEOS when it is withdrawn, or when the visitor (carrier) itself is deleted. 
For more information on withdrawing identifiers, deleting carriers and automatic responses to 
events, see the AEOS User Manual. 

 
 

• Use the Anti Pass Back (APB) option in AEOS to prevent visitors from entering the same zone 
twice in a row or from following an incorrect route. This makes sure that no one can enter an 
APB zone with a QR code that belongs to a visitor who is already inside. For more information, 
see the Anti Pass Back (APB) chapter in the AEOS User Manual. 

• Use the Maximum number of movements option in AEOS to set the number of times the visitor 
(carrier) can access the area. This way, one QR code can only be used once, or a limited 
number of times. For more information, see the Maximum Number of Movements Permitted 
chapter in the AEOS User Manual. 
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• Use the AEOS system properties to restrict the carrier validity of authorisations. See the 
examples below. For more information on changing AEOS system properties, see the AEOS 
User Manual. 

 

AEOS system properties 
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11. Privacy Notices 

11.1 Purpose 
The purpose of the AEOS QR code functionality is to identify carriers that request access to 
physical premises. 

11.2 Method 
Carrier data is entered in AEOS via the AEOS user interface (AEOS Maintenance & Configuration or 
AEOS Dashboard). It is converted to a QR code that can be used as an identifier. A QR code 
identifier comes in a digital or printed form. 

11.3 Data 
AEOS QR codes contain a carrier name, and also a customer code, identifier number, and validity. 

11.4 Storage 
Any carrier data provided to AEOS is stored in a secured AEOS database. 

11.5 Retention 
Any carrier data provided to AEOS will be stored until that information is deleted or changed. 
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Nedap Security Management  
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+31 (0)544 471 111 
info@nedapsecurity.com  
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